Airflow is experiencing issues

Incident Report for Ops4Life

Resolved

Airflow is back online. This incident has been resolved.
Posted Apr 23, 2026 - 04:13 UTC

Investigating

We are currently investigating an issue with Airflow. Updates will be posted here.
Posted Apr 23, 2026 - 03:28 UTC
This incident affected: Airflow.